SlackForum.de
Das deutschsprachige Forum rund um Slackware Linux. Von Usern für User.
Startseite » FAQ - Haeufig gestellte Fragen » FAQ - Haeufig gestellte Fragen [Moderiert] » Deutsches Tastaturlayout Slackware 13.0/13.1/13.37
Deutsches Tastaturlayout Slackware 13.0/13.1/13.37 Mi, 21 Juli 2010 11:17 Zum nächsten Beitrag gehen
ToniCE ist gerade offline ToniCE
Beiträge:1042
Registriert:Februar 2002
Ort: Herne/NRW
Mit der neuen Slackware Version (13.0) kam auch ein neuer X Server auf die Platte. Dieses läuft (bei mir) sogar ohne das anlegen einer xorg.conf...

Jedoch wollte sich kein deutsches Tastaturlayout einstellen. Selbst mit einer frisch erstellten xorg.conf hatte ich noch kein deutsches Tastaturlayout. Also habe ich mich auf die Suche nach einer Lösung gemacht.

Der neue X Server konfiguriert sich selbständig mit Hilfe von HAL. Um darauf einfluss zu nehmen kann man in /etc/hal/fdi/policy Konfigurationsdateien Anlegen.

Um jetzt ein deutsche Layout zu bekommen kopiert man (als root) aus /usr/share/hal/fdi/policy/10osvendor/ die Datei 10-keymap.fdi nach /etc/hal/fdi/policy

cp /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi /etc/hal/fdi/policy/


Danach bearbeitet man die Datei und ändert folgende Zeile:

<merge key="input.xkb.layout" type="string">us</merge>

in
<merge key="input.xkb.layout" type="string">de</merge>


und speichert das.

Nach einem neustart des X Servers sollte dieser auch ein deutsches Tastaturlayout haben.

[Aktualisiert am: Di, 14 Juni 2011 18:40]

Den Beitrag einem Moderator melden

Aw: Deutsches Tastaturlayout ab Slackware 13.0 Fr, 30 Juli 2010 18:30 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Ralf ist gerade offline Ralf
Beiträge:438
Registriert:Mai 2003
Hi,

eine kleine Ergänzung:

um das gewohnte Verhalten der Tastatur herzustellen (keine "toten" Tasten, bei denen das Zeichen erst nach Drücken der nächsten Taste übernommen wird), habe ich noch hinzugefügt:

<merge key="input.xkb.variant" type="nodeadkeys">de</merge>

Ralf

Den Beitrag einem Moderator melden

Aw: Deutsches Tastaturlayout Slackware 13.0/13.1 Di, 14 Juni 2011 10:18 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
markush ist gerade offline markush
Beiträge:261
Registriert:März 2007
Ort: Hückelhoven

Neu ab Slackware 13.37:

da HAL nicht mehr die Tastaturbelegung unter X11 regelt sondern der X-Server das selbst macht muss man jetzt die Datei /usr/share/X11/xorg.conf.d/90-keyboard-layout.conf nach /etc/X11/xorg.conf.d/ kopieren. Diese Datei edieren und anpassen, sie ist selbsterklärend. Nach einem Neustart des X-Server sollte das deutsche Tastaturlayout vorhanden sein.

In dem o.g. Verzeichnis /usr/share/X11/xorg.conf.d/ finden sich noch andere Templates die man genau wie oben beschreiben behandeln kann.

Das im Posting oben beschriebene Vorgehen mit den .fdi-Dateien ist seit Slackware 13.37 obsolet.

Markus

Den Beitrag einem Moderator melden

Aw: Deutsches Tastaturlayout Slackware 13.0/13.1 Sa, 27 August 2011 12:11 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
raleeha ist gerade offline raleeha
Beiträge:23
Registriert:Juni 2011
Ort: Berlin

Hallo,

erstmal danke für das Lesen. Ich hab Probleme mit dem Tastaturlayout. Kriege die deutsche Tastatur nur, wenn ich im Root-Terminal setxkbmap de eingebe. Nutze Slackware 13.0 und habe die obige Anleitung befolgt, jedoch erfolglos. Evt. ist mir ein Fehler unterlaufen. Wäre für Ratschläge dankbar.

<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->

<!-- DO NOT EDIT THIS FILE - IT WILL BE OVERWRITTEN ON UPGRADES.
     SEE THE "READ THIS" NOTE BELOW FOR INSTRUCTIONS -->

<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>

    <match key="info.capabilities" contains="input.keys">

      <!-- Restore Ctrl-Alt-Bksp Xserver Zapping -->
      <merge key="input.xkb.options" type="string">terminate:ctrl_alt_bksp</merge>

      <!-- Edit (as needed) these four lines in the copied fdi file -->
      <merge key="input.xkb.rules" type="string">base</merge>
      <merge key="input.xkb.model" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">de</merge>
      <merge key="input.xkb.variant" type="nodeadkeys">de</merge>

    </match>
  </device>
</deviceinfo>

<!-- READ THIS FOR CUSTOM KEYBOARD INFORMATION

  If you want to add a custom model/layout/variant to X, you will need to COPY
  this file to /etc/hal/fdi/policy/ and edit that copy.  After editing it to
  suit, you will need to leave X, restart the HAL daemon, and start X again.

  Here's an example of the four lines from above:
      <merge key="input.xkb.rules" type="string">base</merge>
      <merge key="input.xkb.model" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">de</merge>
      <merge key="input.xkb.variant" type="string">intl</merge>

  Many desktop environments, including KDE and Xfce, have their own methods to
  configure keyboard layouts and such if you'd like to use them.

  If you prefer to use the "old" way of configuring keyboards (without HAL's
  input device hotplugging), then you'll need to add the following lines to
  the ServerFlags section of /etc/X11/xorg.conf:
    Option   "AllowEmptyInput"     "false"
    Option   "AutoAddDevices"      "false"
    Option   "AutoEnableDevices"   "false"
  You can now edit the Keyboard section of xorg.conf as usual.
-->

Den Beitrag einem Moderator melden

Aw: Deutsches Tastaturlayout Slackware 13.0/13.1 Sa, 27 August 2011 23:01 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
markush ist gerade offline markush
Beiträge:261
Registriert:März 2007
Ort: Hückelhoven

Hallo raleeha,

das hier
<merge key="input.xkb.variant" type="nodeadkeys">de</merge>
ist mit Sicherheit falsch und muss so
<merge key="input.xkb.variant" type="string">nodeadkeys</merge>
aussehen.

Beachte bitte, das das wirklich nur bis einschließlich Slackware-13.1 so funktioniert, ab 13.37 ist HAL nicht mehr für die Belegung zuständig.

Markus

Den Beitrag einem Moderator melden

Aw: Deutsches Tastaturlayout Slackware 13.0/13.1 So, 28 August 2011 17:28 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Ralf ist gerade offline Ralf
Beiträge:438
Registriert:Mai 2003
Hallo raleeha,

ich ha' keine Slackware 13 zur Hand, aber ich vermute, dass es statt

Zitat:

<merge key="input.xkb.layout" type="string">de</merge>
<merge key="input.xkb.variant" type="nodeadkeys">de</merge>


richtig

<merge key="input.xkb.layout" type="string">de</merge>
<merge key="input.xkb.variant" type="string">nodeadkeys</merge>

heissen muss.

Ralf

Den Beitrag einem Moderator melden

Aw: Deutsches Tastaturlayout Slackware 13.0/13.1/13.37 Sa, 22 Oktober 2011 13:54 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
chris_b ist gerade offline chris_b
Beiträge:25
Registriert:April 2008
Hi,

ich habe ein Problem das deutsche Tastaturlayout in KDE zu bekommen.In der Konsole funktioniert es (vor dem Starten des X-Servers).
Ich kann es auch in KDE manuell in der Systemsteuerung auswählen, aber beim nächsten Start von KDE muss ich es erneut auswählen, damit das Layout funktioniert.

Betriebssystem: Slackware 13.37

Ich habe die Anleitung aus CHANGES_AND_HINTS befolgt.
[Ich habe die Datei /usr/share/X11/xorg.conf.d/90-keyboard-layout.conf nach /etc/X11/xorg.conf.d/ verschoben.]

Meine 90-keyboard-layout.conf:
Section "InputClass"
        Identifier "keyboard-all"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "XkbLayout" "de"
        Option "XkbVariant" "nodeadkeys"
        Option "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

In der Datei /var/log/Xorg.log befindet sich ein Absatz mit:
[  1437.332] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
[  1437.332] (**) Option "xkb_rules" "evdev"
[  1437.332] (**) Option "xkb_model" "evdev"
[  1437.332] (**) Option "xkb_layout" "de"
[  1437.332] (**) Option "xkb_variant" "nodeadkeys"
[  1437.332] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"

Das heißt doch, dass die Änderungen angenommen wurden, oder?
Habe ich in der cofig-Datei einen Fehler gemacht?
Ich weis leider nicht mehr weiter, kann jemand helfen?

Den Beitrag einem Moderator melden

Aw: Deutsches Tastaturlayout Slackware 13.0/13.1/13.37 Mo, 24 Oktober 2011 21:52 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
markush ist gerade offline markush
Beiträge:261
Registriert:März 2007
Ort: Hückelhoven

Hallo chris_b,

also testweise starte mal einen anderen Windowmanager, z.B. Fluxbox und teste ob das deutsche Layout da funktioniert. Mit der von Dir geposteten 90-keyboard-layout.conf sollte es gehen. Ich hab das genau so.

KDE hat eine eigene Anpassung. Irgendwo unter Systemeinstellungen->Regionales glaube ich, es kann aber auch sein, dass Du unter Hardware noch was einstellen musst, ich starte gleich mal KDE und teste das.

Markus

Den Beitrag einem Moderator melden

Aw: Deutsches Tastaturlayout Slackware 13.0/13.1/13.37 Mi, 26 Oktober 2011 18:16 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
chris_b ist gerade offline chris_b
Beiträge:25
Registriert:April 2008
Ich habe mich in xfce eigeloggt. Dort konnte ich auf "use system defaults" gehen. Bein nächsten Login hatte ich die deutsche Tatsatur. Ich denke es muss an KDE direkt liegen.

Den Beitrag einem Moderator melden

Aw: Deutsches Tastaturlayout Slackware 13.0/13.1/13.37 Mi, 26 Oktober 2011 21:51 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
markush ist gerade offline markush
Beiträge:261
Registriert:März 2007
Ort: Hückelhoven

Hallo nochmal,

also unter "Systemeinstellungen->Hardware->Eingabegeräte->Tastatur" kannst Du die Belegung anpassen. Es sind dort mehrere Karteireiter, Du musst sowohl den für "Hardware" als auch "Belegung" beachten.

Markus

Den Beitrag einem Moderator melden

Aw: Deutsches Tastaturlayout Slackware 13.0/13.1/13.37 Do, 27 Oktober 2011 20:23 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
chris_b ist gerade offline chris_b
Beiträge:25
Registriert:April 2008
Lösung für KDE:

Unter Systemeinstellungen>Eingabegeräte>Belegung

Den Haken bei "Belegung einrichten" entfernen, dann übernimmt er die Einstellungen, die ich mit der 90-keyboard-layout.conf gemacht habe.

An dieser Stelle: Vielen Dank für den Hinweis ich sollte noch einmal genauer in die KDE Einstellungen schauen, bzw dass es vermutlich ein KDE Problem ist.

Den Beitrag einem Moderator melden

Aw: Deutsches Tastaturlayout Slackware 13.0/13.1/13.37 Sa, 04 Februar 2012 20:01 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
OsunSeyi ist gerade offline OsunSeyi
Beiträge:73
Registriert:August 2009
Hi,
bin Anfänger...
Was hat es denn mit der "xorg.conf-vesa" auf sich?
Aus den obigen Ausführungen entnehme ich, daß sie u.U. vollkommen irrelevant ist?



Slackware 13.37

Den Beitrag einem Moderator melden

Aw: Deutsches Tastaturlayout Slackware 13.0/13.1/13.37 So, 05 Februar 2012 00:21 Zum vorherigen Beitrag gehen
markush ist gerade offline markush
Beiträge:261
Registriert:März 2007
Ort: Hückelhoven

Hallo,

die xorg.conf-vesa ist speziell für die Benutzung mit dem Vesatreiber (das steht so auch in der Datei drin),
Zitat:
# NOTE: This is a NEW IMPROVED version of XF86Config-fbdev that uses the vesa
# driver instead of the fbdev driver. Thanks to Kenneth Fanyo who pointed
# this out to me.

# This XF86Config file is designed for use with the VESA framebuffer.
# This generic interface should work with nearly all video cards
# (although not every card will support every resolution).

# With the new driver, it should no longer be required to have frame buffer
# support in the kernel, or to run it on the console.
#
# Enjoy!
# -- volkerdi@slackware.com
#

Die Datei wird aber nur benutzt, wenn sie unter dem Namen "xorg.conf" gespeichert wird. Genauer: wenn eine xorg.conf vorhanden ist, dann wird sie auch gelesen und überschreibt die "normalen", sonstigen Einstellungen. Diese normalen Einstellungen werden vom X-Server automatisch vorgenommen bzw. in den Dateien in /etc/X11/xorg.conf.d/ festgelegt.

Markus

Den Beitrag einem Moderator melden

Vorheriges Thema: Slackware-Links
Gehe zum Forum:
  


aktuelle Zeit: Di Mär 28 04:23:12 CEST 2017

Insgesamt benötigte Zeit, um die Seite zu erzeugen: 0.01224 Sekunden